阿里云香港云虛擬主機如何升級PHP新版本

  • 阿里云香港云虛擬主機如何升級PHP新版本已關閉評論
  • A+

好尷尬,好久沒有更新文章了,今天,心血來潮。最近wordpress程序5.2版本升級碰上了困難,升級5.2后網站出現了白屏,直接打不開。原因是使用5.3版本的PHP,而現在的wordpress官方要求PHP版本需要7.0以上。

一、升級步驟:

既然問題來了,就得解決,折騰了一下,總算搞定,阿里云香港虛擬主機提供的能夠升級的PHP最高版本是7.1,我們就選擇7.1版本,如下圖所示。

阿里云香港云虛擬主機如何升級PHP新版本

步驟一:點擊保存設置——確定——設置完成。

第二步:將數據庫密碼升級為41位加密,這步一定要做,密碼可以用原來的密碼。如上圖點擊藍色字——進入數據庫信息界面——選擇重置密碼——在提示框點擊確定——輸入數據庫登錄密碼——加密模式選擇41位——設置好好點擊確定——這樣升級成功。

阿里云香港云虛擬主機如何升級PHP新版本

二、升級PHP注意事項:

不過,升級wordpress的PHP版本之前,還需要做好相關插件是否兼容,具體可使用插件PHP Compatibility來檢查,插件可在后臺安裝插件搜索插件名安裝就可以。

安裝后,進入插件配置頁面: 工具 -> PHP Compatibility,如下圖:

阿里云香港云虛擬主機如何升級PHP新版本

我們打算升級到哪個版本的PHP ,就選擇哪個版本,(如果是網頁空間,可以先進空間面板查看可升級的PHP版本,建議選擇最高版本以獲得更優性能)。選擇版本后點擊Scan site按鈕,等待幾分鐘后,將得出掃描結果:

阿里云香港云虛擬主機如何升級PHP新版本

綠色代表兼容,黃色表示該插件更新后可兼容,紅色表示不兼容,灰色表示無法讀取。

注意:如果出現紅色,就需要對相應的代碼進行調整,否則升級PHP 后,可能會出現網站500的錯誤。我直接卸載了不兼容插件,使用別的插件替代。

此外,升級之前需要做好網站備份、數據庫備份工作,雖然很少會出現問題,但是以防萬一。